In-App Billing Affected
Incident Report for Formstack
Resolved
Access to the Billing page on your Formstack account and forms has been fully restored. Our Developers will continue to monitor our Billing vendor, Zuora, and we will post an update should the status change.

In the meantime, if you continue to experience issues accessing the Billing page on your Formstack account, make sure you have admin account permissions. If you do, and you are still unable to access the Billing page, please reach out to our Support team and include any error message(s) you're seeing.
Posted 18 days ago. Oct 01, 2019 - 19:23 EDT
Investigating
We are currently experiencing a service disruption impacting Billing access in Formstack.com.

This downtime is due to a current outage with our billing vendor, Zuora. During this time, your Formstack Account, Form Users, Submissions, etc. will not be affected. We will be posting additional status updates as soon as they come in or within the next 30-minutes.
Posted 18 days ago. Oct 01, 2019 - 15:07 EDT
This incident affected: Main Application.