Comcast/Xfinity Users not able to access formstack.com URLs
Incident Report for Formstack
Resolved
The core issue has been resolved and we've discussed preventative steps with a third party to help mitigate any future instances of this.
Posted 7 months ago. Feb 16, 2017 - 14:26 EST
Monitoring
Xfinity & Comcast users should be able to reach Formstack.com and Forms again. We're still working towards a more permanent solution.
Posted 7 months ago. Feb 14, 2017 - 19:24 EST
Identified
We're seeing new instances of connection issues for Xfinity/Comcast users. We're working on a new mitigation and will update soon.
Posted 7 months ago. Feb 14, 2017 - 19:16 EST
Update
We're confident that the issue is resolved, but we're leaving this issue in Monitoring while we work with a third party to ensure the solution is permanent.
Posted 7 months ago. Feb 13, 2017 - 08:43 EST
Monitoring
We've implemented a change on our end that should allow Formstack.com to load again for Comcast users. It may take a few minutes to take affect on your devices.
Posted 7 months ago. Feb 12, 2017 - 12:50 EST
Identified
We're still working on restoring access to Formstack for Comcast users.
Posted 7 months ago. Feb 12, 2017 - 12:33 EST
Investigating
We've received reports indicating that Comcast users are not able to load Formstack.com or Formstack Forms. We're investigating the root cause and are working on a solution.
Posted 7 months ago. Feb 12, 2017 - 11:59 EST