Formstack site loading affected
Incident Report for Formstack
Resolved
This incident has been resolved.
Posted Dec 09, 2019 - 18:01 EST
Monitoring
We have identified the issue and have implemented a solution. Access to your Formstack account and forms has been fully restored. We will continue to monitor this activity and share a full post-mortem shortly with more details regarding this incident.
Posted Dec 09, 2019 - 13:36 EST
Investigating
We are currently experiencing a service disruption impacting the load time of Formstack.com.

Our Development teams are working to identify the root cause and implement a solution. During this time, your Formstack Account may be affected. We will be posting additional status updates as soon as they come in or within the next 30-minutes.
Posted Dec 09, 2019 - 10:37 EST
This incident affected: Main Application.