502 Bad Gateway Errors
Incident Report for Formstack
Resolved
After close, extensive monitoring overnight, we are comfortable with the level of stability that we continue to see. Therefore, we are marking this incident as resolved.

Thank you for your patience and understanding!
Posted Nov 24, 2020 - 08:40 EST
Monitoring
After implementing some additional fixes, we are seeing a return to normalcy. We will continue to monitor performance and make any necessary adjustments as needed.
Posted Nov 23, 2020 - 16:06 EST
Update
We are continuing to work toward a solution. At this time, we are seeing more instability than we would like and some users may experience slowness and/or timeouts. We will continue to update as we work toward stability.
Posted Nov 23, 2020 - 15:27 EST
Update
We are seeing increased stability after implementing a fix. We will continue to monitor Forms to ensure that performance continues in the right direction, and will issue an update once we're confident things have returned to normal.
Posted Nov 23, 2020 - 15:04 EST
Identified
We have identified the root cause of the 502 Errors and are working toward implementing a fix.
Posted Nov 23, 2020 - 13:29 EST
This incident affected: Main Application and Forms (Hosted & Embedded).