Formstack Account accessibility
Incident Report for Formstack
Resolved
Formstack Account accessibility issues have been resolved. If you experience any issues with your Account, please contact the Formstack Support Team. Thank you for your patience!
Posted 2 months ago. Dec 15, 2017 - 13:55 EST
Update
Formstack Account access should be restored for all Users however we are continuing to monitor before declaring a full resolution.
Posted 2 months ago. Dec 15, 2017 - 12:04 EST
Monitoring
We have identified the issue and have begun implementing a resolution for Account access. We are continuing to monitor server response times and expect full access to be restored shortly.
Posted 2 months ago. Dec 15, 2017 - 11:33 EST
Identified
We have identified a service disruption impacting accessibility and preventing Account Users from logging into Formstack.

Our Development teams have identified the root cause and are working towards a solution. During this time, your Formstack Account access may be affected. We will post additional status updates as soon as they come in or within the next 30 minutes.
Posted 2 months ago. Dec 15, 2017 - 11:24 EST