Formstack Account accessibility
Incident Report for Formstack
Resolved
We've identified the issue preventing Formstack Account access and have released these fixes to the live site. If you continue to experience problems accessing your Account, please contact Formstack Support.
Posted 5 months ago. Jul 27, 2017 - 17:15 EDT
Identified
We are currently experiencing accessibility issues preventing Account Users from logging into Formstack. This is only affecting the ability to log into your Formstack Account; live Forms and Submissions are unaffected.

We will continue to update this page as new information and corrective action has been taken.
Posted 5 months ago. Jul 27, 2017 - 17:00 EDT