Support Tickets affected
Incident Report for Formstack
Resolved
All known issues related to this incident have been resolved. We thank you for your patience and co-operation.
Posted Jul 17, 2020 - 21:33 EDT
Update
We are continuing to monitor for any further issues.
Posted Jul 17, 2020 - 17:39 EDT
Monitoring
Our Support ticket portal, Zendesk, is currently reporting an outage that is preventing us from accessing Support tickets. Access to your Formstack account and forms should not be affected. We will continue to monitor this activity. For more information, please visit https://status.zendesk.com/.
Posted Jul 17, 2020 - 17:33 EDT
This incident affected: Formstack Support Portal (Support Help Site, Support Ticketing).