Builder failure
Incident Report for Formstack
Resolved
This incident has been resolved.
Posted 5 months ago. Jul 20, 2017 - 11:07 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 5 months ago. Jul 20, 2017 - 10:27 EDT
Identified
We've identified an issue preventing Form Builder from loading and are working on a fix. Form embeds and other parts of the application are up and running.
Posted 5 months ago. Jul 20, 2017 - 10:11 EDT