Site not accepting traffic
Incident Report for Formstack
Resolved
We have resolved this issue and are taking steps for this not to occur again.
Posted 11 months ago. Jul 05, 2017 - 12:15 EDT
Identified
We've identified an issue where our system is not accepting incoming traffic and causing requests to fail. We are working on a fix.
Posted 11 months ago. Jul 05, 2017 - 12:10 EDT