Form Submissions Affected
Incident Report for Formstack
Resolved
We have identified the issue and have implemented a solution. Access to your Formstack forms has been fully restored. We will post a full post-mortem shortly with more details regarding this incident.
Posted 4 months ago. May 29, 2019 - 18:03 EDT
Identified
We are currently experiencing a service disruption impacting form behavior, specifically form submissions.

Our Development teams have identified the root cause and are working towards a solution. During this time, your Formstack forms may be affected. You may encounter the error 500.

We will post additional status updates as soon as they come in.
Posted 4 months ago. May 29, 2019 - 17:43 EDT
This incident affected: Forms (Hosted & Embedded).