Formstack Account & Form accessibility issues
Incident Report for Formstack
Resolved
The Account accessibility and live Form issues have been resolved but we are continuing to monitor this behavior closely. If you experience any issues with your Forms or Account, please contact the Formstack Support Team. Thank you for your patience!
Posted 5 months ago. Jan 30, 2018 - 11:54 EST
Update
Our Team has identified the issue and have begun implementing a resolution to restore all Account and Form access. Those updates will be deployed shortly. We will continue to monitor and share updates with you as they come in.
Posted 5 months ago. Jan 30, 2018 - 11:40 EST
Identified
We have identified a service disruption impacting accessibility and preventing Account Users from logging into Formstack and/or accessing live Forms.

Our Development teams have identified the root cause and are working towards a solution. During this time, your Formstack Account access and live Forms may be affected. We will post additional status updates as soon as they come in or within the next 30 minutes.
Posted 5 months ago. Jan 30, 2018 - 11:27 EST