Help Portal Site Outage
Incident Report for Formstack
Resolved
Access to all Formstack Help portals and the ticketing systems have been fully restored. We will continue to monitor all systems and process through any previously submitted requests to our Help Site or from direct email. Responses may be slightly delayed, however, we will respond to all inquiries as soon as possible.

Thank you for your patience as our Support systems are being restored for Formstack users.
Posted 21 days ago. Jul 02, 2019 - 10:45 EDT
Monitoring
Corrective action has been administered across the Formstack Help Portals and ticketing systems. Help Portal access has been fully restored and is currently being monitored.
Posted 21 days ago. Jul 02, 2019 - 10:21 EDT
Identified
Our Help Desk site provider is currently experiencing intermittent issues affecting access to our Help Portal Sites and resulting in delayed response times to Support requests.

We will continue to update this page and in the meantime, please send any Support requests to support@formstack.com and we will respond to all requests as soon as possible.
Posted 21 days ago. Jul 02, 2019 - 10:08 EDT
This incident affected: Support Portal (Support Help Site, Support Ticketing).