Comcast/Xfinity Users not able to Access Formstack.com URLs
Incident Report for Formstack
Resolved
This incident has been resolved.
Posted 4 months ago. Feb 19, 2017 - 18:37 EST
Identified
We're seeing a new batch of connection issues to Formstack from Xfinity users. We're working on getting access restored.
Posted 4 months ago. Feb 19, 2017 - 18:12 EST