Support Site Outage
Incident Report for Formstack
Resolved
Desk.com (http://www.desk.com/trust) has fully restored our Support help site and all inbound and outbound cases have caught up.  Overall performance is being monitored closely by Desk engineers.

Please continue to submit questions to support.formstack.com or support@formstack.com and we will respond as soon as possible.
Posted Jan 29, 2016 - 08:06 EST
Monitoring
Desk.com is experiencing issues affecting our Support help site and resulting in delayed response times to Support Team requests. To see more on these outages and expected up-times, please see the Desk Trust page (https://www.desk.com/trust).

Please continue to send questions and tickets to support@formstack.com and we will get back to you as soon as possible.
Posted Jan 28, 2016 - 11:57 EST