Slow Response Times
Incident Report for Formstack
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 07, 2017 - 17:24 EST
Monitoring
We are continuing to monitor the slower than normal response times but at the current time are not experiencing any issues.
Posted 3 months ago. Mar 07, 2017 - 15:38 EST
Investigating
We are currently investigating slower than normal response times.
Posted 3 months ago. Mar 07, 2017 - 12:31 EST