Forms and Application Issues
Incident Report for Formstack
Resolved
We have since resolved the issue we found that was causing queries to back up on our database server. All services should be operational.
Posted 9 months ago. Sep 08, 2016 - 10:28 EDT
Monitoring
We have identified an issue that caused forms and the application to become unusable for a few minutes this morning. We are monitoring the situation closely.
Posted 9 months ago. Sep 08, 2016 - 09:47 EDT