Performance Issues
Incident Report for Formstack
Resolved
This incident has been resolved.
Posted 12 months ago. Feb 24, 2017 - 06:46 EST
Update
We have an update rolling out that should help with the performance issues. Users may experience an issue where they are logged out of the system when this update is deployed.
Posted 12 months ago. Feb 23, 2017 - 15:00 EST
Monitoring
Performance seems to have resolved for the time being. We're keeping an eye on things and will be rolling out an update soon that should help prevent future performance issues like this.
Posted 12 months ago. Feb 23, 2017 - 13:33 EST
Identified
We're seeing some slowness and other performance issues with Formstack.com. We're working on a solution. In the meantime, users logged into Formstack may be logged out.
Posted 12 months ago. Feb 23, 2017 - 11:57 EST