Formstack Login Affected
Incident Report for Formstack
Resolved
We have identified issue and have implemented a solution. Access to your Formstack account and forms has been fully restored. We will post a full post-mortem shortly with more details regarding this incident.
Posted 7 months ago. Aug 17, 2018 - 02:30 EDT
Identified
We are currently experiencing a service disruption impacting Formstack.com login activity.

Our Development teams have identified the root cause and are working towards a solution. During this time, your Formstack account may be affected. That said, your Formstack forms should still be operational and will continue to receive submissions.

We will post additional status updates as soon as they come in or within the next 30 minutes.
Posted 7 months ago. Aug 17, 2018 - 02:29 EDT
This incident affected: Main Application.