Formstack Email deliverability issues identified
Incident Report for Formstack
Resolved
All Email deliverability issues have been resolved and returned to normal operating behavior. We are continuing to monitor the Email queue closely to ensure all system messages are being sent.

Please note that Emails attempting to send between 12:04 pm and 1:40 pm ET were affected by the deliverability issues however collected data and submissions were not affected.

Certain emails may not be available for resending, however, you will be able to resend your Notification Emails. For more on resending Notification Emails, please click here: https://support.formstack.com/customer/en/portal/articles/1715424

If you continue to experience issues with Email deliverability, please contact the Formstack Support Team. Thank you for your patience!
Posted 2 months ago. Feb 13, 2018 - 14:10 EST
Monitoring
Our Team has identified the issue affecting Email deliverability and have begun implementing the resolution. These updates will be deployed shortly and we will continue to monitor Email activity and share updates with you.
Posted 2 months ago. Feb 13, 2018 - 13:48 EST
Identified
We have identified a service disruption impacting the deliverability of Emails from Formstack. This is preventing emails generating from Formstack to send out, including Notification, Confirmation, Approvals, Workflows, and system messages (i.e. password reset requests)

Our Development teams have identified the root cause and are working on the solution. We will post additional status updates as soon as they come in or within the next 30 minutes.
Posted 2 months ago. Feb 13, 2018 - 13:40 EST