Submissions to Google Sheets Affected
Incident Report for Formstack
Resolved
On Tuesday, September 19, 2017, at approximately 12:30 AM ET, we identified an issue with our Google Sheets integration failing to send data upon form submit. During this time, submitted data could be collected on your form, but it may not have posted to your Google Sheet(s).

Our Development Team was able to isolate the issue to a worker bottleneck, and at approximately 9:00 AM ET on Tuesday, September 19, 2017, they confirmed that the backlogged submissions are starting to clear out and data was posting to Google Sheets. If you have submissions that didn't post to Google, you can rerun the integration in your submissions page to push the data through manually.

We apologize for any delays or confusion this caused. We have increased the quotas to prevent this from happening again.
Posted 5 months ago. Sep 19, 2017 - 11:17 EDT
Monitoring
We have identified the Google Sheets integration issue and have implemented a solution. Access to your Formstack account and forms have not been affected. As long as you're still within your submission data limit, your actual submissions will be saved in your Formstack account.

You may continue to receive the Google Sheets error as there is still a slight delay while the queue resets. We will continue to monitor this activity and share a full post-mortem with more details regarding this incident.
Posted 5 months ago. Sep 19, 2017 - 00:43 EDT
Identified
We are currently experiencing a service disruption impacting Google Sheets integrations.

Our Development teams have identified the root cause and are working towards a solution. During this time, your Formstack submissions to this integration may be affected. We will post additional status updates as soon as they come in or within the next 30 minutes.
Posted 5 months ago. Sep 18, 2017 - 23:56 EDT