Slow response times
Incident Report for Formstack
Resolved
This incident has been resolved.
Posted 2 months ago. Mar 20, 2017 - 16:55 EDT
Monitoring
The slow response times should have stopped. We are continuing to monitor to make sure there are no other issues.
Posted 2 months ago. Mar 20, 2017 - 15:24 EDT
Identified
We apologize for the slow response times some customers may be experiencing. We have identified the issue and are working on a solution.
Posted 2 months ago. Mar 20, 2017 - 13:39 EDT
Update
We are continuing to investigate the slow response times on the site. We are working on mitigating the issues.
Posted 2 months ago. Mar 20, 2017 - 12:42 EDT
Investigating
We are investigating an issue that might cause some users to have slow response times on the application.
Posted 2 months ago. Mar 20, 2017 - 12:06 EDT