Emails deliveries delayed
Incident Report for Formstack
Resolved
SendGrid our email provide has fully restored all outgoing email notifications. Emails are processing now without delay and overall performance is being monitored closely by SendGrid engineers.

Please continue to submit questions to support.formstack.com or support@formstack.com and we will respond as soon as possible.
Posted 10 months ago. Sep 02, 2016 - 15:44 EDT
Monitoring
Our email provider, SendGrid, is currently experiencing deliverability delays affecting Notification, Confirmation & Approval Emails. To see more on these outages and expected up-times, please see visit the SendGrid Status page (http://status.sendgrid.com).

We will continue to update this page as the status changes. In the meantime, please be assured that all emails queued during this time will be sent as soon as the delays have been cleared.
Posted 10 months ago. Sep 01, 2016 - 15:47 EDT