Formstack account and form submissions displaying errors
Incident Report for Formstack
Resolved
The Formstack Account and Form submission errors have been fully resolved. All forms and application access are back online and fully operational once again. We greatly appreciate your patience while we worked through these issues!
Posted 9 months ago. Dec 19, 2018 - 14:59 EST
Monitoring
We have identified the source of the Account and Form error messages and have implemented the solution. Use of your Formstack account and Form submissions can now be accessed and submissions processed without returning the previously experienced errors.

We are continuing to monitor this activity and will post additional details once this has been fully resolved.
Posted 9 months ago. Dec 19, 2018 - 14:24 EST
Investigating
We are currently experiencing a service disruption impacting certain functions within Formstack accounts and upon submission of some Formstack Forms. This will manifest in an error message when attempting to access your Formstack account or when submitting certain forms.

Our Development teams are working to identify the root cause and implement a solution. During this time, your Formstack account and/or Form submissions may be affected. We will be posting additional status updates as soon as they come in or within the next 30-minutes.
Posted 9 months ago. Dec 19, 2018 - 14:06 EST
This incident affected: Main Application and Forms (Hosted & Embedded).