Shared Submissions Link Issue
Incident Report for Formstack
Resolved
We have identified the issue and have implemented a solution. Access to your Formstack shared submission URLs has been fully restored.
Posted Nov 20, 2019 - 17:52 EST
Investigating
We are currently experiencing a service disruption impacting Shared Submissions.

Our Development teams are working to identify the root cause and implement a solution. During this time, Shared Submissions reports may be affected. You will continue to receive and log submissions as per usual.
We will be posting additional status updates as soon as they come in or within the next 30-minutes.
Posted Nov 20, 2019 - 17:30 EST
This incident affected: Formstack Forms (Main Application).