Performance Issues
Incident Report for Formstack
Resolved
This incident has been resolved.
Posted 9 months ago. Mar 01, 2017 - 12:56 EST
Identified
We're seeing reports of slowness accessing Formstack.com and forms built with Formstack. We have a potential solution we're going to attempt shortly.
Posted 9 months ago. Mar 01, 2017 - 12:05 EST