Support Responses Delayed
Incident Report for Formstack
Resolved
The Support Email server issue has been resolved; all support emails are sending and operating normally once again. We will continuing to monitor these mailboxes to ensure messages continue to transmit as expected. Thank you for your patience during these delays.
Posted 11 months ago. Oct 21, 2016 - 17:12 EDT
Update
All previously delayed outbound messages have been sent and are now up to date. The email delay incident is still under investigation so we will continue to provide updates until the issue has been fully resolved.
Posted 11 months ago. Oct 21, 2016 - 14:14 EDT
Identified
Our Help Desk provider (Desk.com) is currently experiencing delays in sending and receiving emails, resulting in delayed response times to Support requests. To see more on this outage and expected up-times, please https://status.desk.com

Updates will also be posted to this page and in the meantime, please continue to send your Support requests to support@formstack.com and we will respond as soon as possible.
Posted 11 months ago. Oct 21, 2016 - 13:52 EDT