Slow response times.
Incident Report for Formstack
Resolved
Customers should no longer be experiencing problems with slowness. Thank you!
Posted 4 months ago. Mar 08, 2017 - 20:00 EST
Monitoring
Although the issue seems to have resolved itself, we will continue to monitor this for the short time being!
Posted 4 months ago. Mar 08, 2017 - 15:07 EST
Investigating
We are investigating an issue that might cause some users to have slow response times on the application.
Posted 4 months ago. Mar 08, 2017 - 14:58 EST