Google Sheets Integration
Incident Report for Formstack
Resolved
This incident has been resolved.
Posted Jun 23, 2020 - 16:12 EDT
Monitoring
We are currently experiencing an increase in processing time for submissions to integrate with Google Sheets. All other submission functions are performing as intended.
Posted Jun 23, 2020 - 13:03 EDT
This incident affected: Formstack Forms - Third Party Integrations (Google Sheets).