SMS 2FA Login and Verification Issues due to Third-Party Service Provider
Incident Report for Formstack
Resolved
Twilio's services are back up and running. For further information, check out their status page here: https://status.twilio.com/
Posted Feb 26, 2021 - 11:20 EST
Identified
We are aware that some users are experiencing difficulty logging in. Specifically, users who have 2 Factor Authentication set up with SMS (text) messages. This is due to an outage by Twilio, the service provider for the SMS 2FA method. Additionally, Formstack Sign users may experience issues with SMS/Text verification. You can follow their Status Page here: https://status.twilio.com/
Posted Feb 26, 2021 - 10:15 EST
This incident affected: Formstack Sign (Main Application), Formstack Documents (Website & Management Portal), and Formstack Forms (Login SSO (Single sign-on)).