Payment Processor Issue
Incident Report for Formstack
Resolved
This incident has been resolved.
Posted Jan 04, 2022 - 16:49 EST
Identified
We are currently experiencing technical issues with our payment processor, which we expect to be resolved no later than Tuesday January 4th.

During this time, you may experience errors while attempting to change or update your subscription plan or credit card payment information within the application. We apologize for any inconvenience and are working with our vendor to correct this issue as rapidly as possible.
Posted Jan 03, 2022 - 12:36 EST
This incident affected: Formstack Sign (Billing Portal), Formstack Documents (Billing Services), Formstack Forms (Billing Portal), and Formstack for Salesforce (Billing Portal).