Formstack for Salesforce Users Unable to Create or Edit Forms
Incident Report for Formstack
Resolved
This incident has been resolved.
Posted Jan 11, 2022 - 11:37 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 10, 2022 - 17:07 EST
Identified
Our team is aware of the issue that is currently impacting some users from being able to create and edit forms from within the Formstack for Salesforce Dashboard. We are actively working on a fix and should have something released to all orgs soon.
Posted Jan 10, 2022 - 14:55 EST
This incident affected: Formstack for Salesforce (Salesforce Application).