Unable to login to Formstack Forms
Incident Report for Formstack
Resolved
Our team has completed investigation on this incident. The Formstack Forms application was out of service for roughly 25 minutes due to connection issues within the AWS environment.
Posted Oct 04, 2021 - 10:44 EDT
Monitoring
Formstack admin services are once again operational. We are still investigating the root cause of the problem and will continue to monitor application performance.
Posted Sep 30, 2021 - 16:52 EDT
Investigating
We are currently investigating an issue where users are unable to access the Formstack Forms product.
Posted Sep 30, 2021 - 16:30 EDT
This incident affected: Formstack Forms (Main Application).