Slow Response Times
Incident Report for Formstack
Resolved
Response times should now be back to normal. Connection speeds to the database have been resolved.
Posted about 2 months ago. May 02, 2017 - 15:40 EDT
Identified
We are currently experiencing some slower than normal connection times to our database. We are aware of the issue and looking into it.
Posted about 2 months ago. May 02, 2017 - 15:09 EDT