Formstack Account and Form access affected
Incident Report for Formstack
Resolved
Formstack Account and Form access issues have been fully resolved. All forms and application access are back online and operational once again. We greatly appreciate your patience while we worked through these issues!
Posted 3 months ago. Apr 10, 2018 - 08:29 EDT
Monitoring
We have identified the issue impacting Form and Account access and have implemented a solution. Access to your Formstack account and forms has been fully restored.

We will continue to monitor this activity and share additional updates and details regarding this incident.
Posted 3 months ago. Apr 10, 2018 - 08:14 EDT
Identified
We are currently experiencing a service disruption impacting Forms and access to Formstack application Accounts.

Our Development teams have identified the root cause and are working towards a solution. During this time, your Formstack Account and Forms may be affected. We are working on a resolution with the highest priority and will post additional status updates shortly.
Posted 3 months ago. Apr 10, 2018 - 08:10 EDT