Confirmation Email Delays
Incident Report for Formstack
Resolved
Confirmation email queues have returned to normal levels.
Posted Jan 12, 2021 - 18:58 EST
Monitoring
We have pushed a fix that appears to be addressing the email delivery delay. We are monitoring the queue and, based on current projections, we anticipate that the queue should be cleared approximately within the next hour.
Posted Jan 12, 2021 - 16:49 EST
Investigating
We have been made aware that some users are experiencing delays in receiving confirmation emails. We are investigating the cause and will provide an update once we have some more information.
Posted Jan 12, 2021 - 15:58 EST
This incident affected: Main Application.