Support Site Outage
Incident Report for Formstack
Resolved
Desk.com (https://status.desk.com) has fully restored all affected Support Help sites. Inbound and Outbound cases are processing and overall performance is being monitored closely by Desk engineers.

Please continue to submit questions to support.formstack.com or support@formstack.com and we will respond as soon as possible.
Posted 10 months ago. Aug 17, 2016 - 10:36 EDT
Monitoring
Desk is continuing to investigate site accessibility and latency issues; please expect another update shortly.
Posted 10 months ago. Aug 17, 2016 - 09:50 EDT
Identified
Desk.com is currently experiencing intermittent issues affecting access to our Support Help site and resulting in delayed response times to Support requests. To see more on these outages and expected up-times, please see the Desk Trust page (https://www.desk.com/trust).

We will continue to update this page and in the meantime, please send any Support requests to support@formstack.com and we will get back to you as soon as possible.
Posted 10 months ago. Aug 17, 2016 - 09:28 EDT