Stripe Payment Forms affected
Incident Report for Formstack
Resolved
On Tuesday, September 10, 2019, at approximately 2:40 PM ET, we identified an issue with forms offering multiple payment options that also had the Stripe integration enabled. During this time, when end-users selected the non-Stripe related option, an error message appeared, barring them from completing the submission.

Our Development Team was able to isolate the issue to the new Stripe integration we released, and at approximately 3:00 PM ET on Tuesday, September 10, 2019, they confirmed that the update was rolled back and the affected forms' full functionalities were restored.

We apologize for any delays or confusion this caused.
Posted 5 days ago. Sep 10, 2019 - 18:38 EDT
Update
We are continuing to monitor for any further issues.
Posted 5 days ago. Sep 10, 2019 - 15:12 EDT
Monitoring
We have implemented a solution. We will continue to monitor this activity and share a full post-mortem shortly with more details regarding this incident.
Posted 5 days ago. Sep 10, 2019 - 15:12 EDT
Identified
We are currently experiencing a service disruption impacting forms with multi-payment options and the Stripe payment integration enabled.

On these forms, when a user selects another payment option besides Stripe, they encounter an error message, barring them from submitting the form.

Our Development teams have identified the root cause and are working towards a solution. During this time, your Formstack submissions may be affected. We will post additional status updates as soon as they come in or within the next 30 minutes.
Posted 5 days ago. Sep 10, 2019 - 15:06 EDT
This incident affected: Forms (Hosted & Embedded).