Degraded Performance
Incident Report for Formstack
Resolved
This incident has been resolved.
Posted 3 months ago. May 23, 2017 - 13:50 EDT
Identified
We are currently experiencing slower than normal response times. We have identified the issue and are working to resolve it.
Posted 3 months ago. May 23, 2017 - 11:20 EDT