Delay in Email Delivery
Incident Report for Formstack
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 17, 2017 - 11:49 EDT
Monitoring
We are currently experiencing a delay in emails being sent and are monitoring the situation.
Posted about 1 month ago. Jul 17, 2017 - 10:25 EDT