Application Outage
Incident Report for Formstack
Resolved
This incident has been resolved.
Posted 4 months ago. May 12, 2019 - 22:57 EDT
Investigating
From 8:15 PM ET to 8:30 PM ET on Sunday, May 12th the Formstack application experienced a service disruption that made the application and forms unavailable. Our development team was able to identify and correct the root cause and will continue to monitor the situation. As of 8:30 PM ET on May 12th forms and the application are once again fully functional.
Posted 4 months ago. May 12, 2019 - 21:15 EDT
This incident affected: Main Application.