Formstack Support Portal Outage
Incident Report for Formstack
Resolved
The Formstack Help Portal hosted at Desk.com and all access has been fully restored. Inbound and Outbound ticketing is processing now and overall performance is being monitored closely.

Please continue to submit questions to support.formstack.com and we will respond as soon as possible. We appreciate your patience during this time.
Posted 5 months ago. Oct 12, 2018 - 16:07 EDT
Update
We are continuing to work on a fix for this issue.
Posted 5 months ago. Oct 12, 2018 - 15:05 EDT
Identified
The Formstack Help site hosted at Desk.com is currently experiencing intermittent issues affecting access to our Support Help Portal and may result in delayed response times to Support requests. To see more on these outages and expected up-times, please see the Desk Trust page (https://status.desk.com).

We will continue to update this page and in the meantime, please send any Support requests to support@formstack.com and we will respond to these as soon as possible.
Posted 5 months ago. Oct 12, 2018 - 14:47 EDT
This incident affected: Support Portal (Support Help Site, Support Ticketing).